PHP 5.6 Shift

The PHP 5.6 Shift upgrades your PHP code to be compatible with PHP 5.6.

Requirements

A PHP codebase compatible with PHP 5.5.

Why upgrade to PHP 5.6?

PHP 5.6 is the final version of the PHP 5 release and will receive active support until the end of 2016. As such PHP 5.6 is a last stop before upgrading to PHP 7.

PHP 5.6 Upgrade

The PHP 5.6 Shift upgrades your code to PHP 5.6, including:

  • Translating changed and deprecated functions
  • Warning about backward incompatibilities
  • Detecting removed INI directives
  • Normalizing syntax to the latest conventions

Still have questions? Message @shiftphp on Twitter or email shift@php-shift.com.